Global Transfer and Balance Impact

Incident Report for Wise

Resolved

This incident has now been resolved.
Posted Aug 01, 2025 - 18:13 BST

Identified

The issue has been identified. Balance functionality has now been restored; however, transfers are still delayed. Teams are working to resolve the transfers delays.
Posted Aug 01, 2025 - 17:34 BST

Investigating

We’re experiencing an issue affecting the sending of transfers and balance functionality globally. The teams are working to resolve it and will update the status accordingly.
Posted Aug 01, 2025 - 16:55 BST
This incident affected: 💱 Account and 💸 Payments.