Issue with Instant payments
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 18:09 GMT
Monitoring
Between 12:18 and 12:43 we experienced a technical issue. As a result, it took longer than usual to process payments that are normally instant. This issue also impacted Wise Platform customers.

We've already implemented a fix and returned to normal processing..
Posted Jan 18, 2024 - 13:16 GMT