Issue with card and Apple Pay pay-ins

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 14:46 GMT

Investigating

We are currently experiencing an issue which affects all card and Apple Pay pay-ins to Wise accounts. Our team is working to fix this as soon as possible.
Posted Nov 11, 2025 - 13:58 GMT
This incident affected: 💸 Payments.