Issue with transfers and Wise Account top ups
Incident Report for Wise
Resolved
Between 08:05-09:04 UTC, we experienced an issue impacting transfers and Wise Account top ups. As a result, impacted customers faced issues when funding their Wise Account and delays with their transfers. This issue has now been resolved.
Posted May 21, 2024 - 10:28 BST