EUR payments delayed

Incident Report for Wise

Resolved

This incident has been resolved.
Posted May 05, 2025 - 14:09 BST

Monitoring

We're aware of an issue affecting EUR payments due to delays in TARGET2, the real-time gross settlement system operated by the Eurosystem. As a result, transfers in EUR may be taking longer than usual to arrive. Please be assured that we are actively monitoring the situation and working to resolve it.
Posted May 05, 2025 - 13:30 BST
This incident affected: 💸 Payments and 🔗 API.