A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2024 - 17:31 BST
Investigating
We are experiencing an issue with payouts which are currently delayed, with top ups and with verification. We are working on a fix and to resolve this as soon as possible.
Posted Jul 01, 2024 - 14:45 BST
This incident affected: 📱 Mobile App, 📰 Website, 💱 Account, 💸 Payments, and 🔗 API.