Issue when authenticating
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Mar 07, 2024 - 16:43 GMT
Monitoring
There is an issue with authenticating accounts and transfers on our platform, using certain authentication methods. Other methods are available and customers access their accounts and use our services without problems.
Posted Mar 07, 2024 - 15:30 GMT