Delayed payouts
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Jun 20, 2024 - 16:05 BST
Investigating
We are experiencing an issue with payouts which are currently delayed.
We are working on a fix and to resolve this as soon as possible.
Posted Jun 20, 2024 - 15:22 BST
This incident affected: 💸 Payments and 🔗 API.