Issue with logging in and completing transfers
Incident Report for Wise
Resolved
On Monday, 1 Jan, between 17:58-18:16 UTC and 18:30-18:33 UTC, we experienced an issue where customers were not able to log in or complete transfers. This also impacted partners integrating the Wise API. This issue has now been resolved.
Posted Jan 01, 2024 - 18:00 GMT