Intermittent Transfers Error

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 18:19 BST

Investigating

We are experiencing an issue that is causing intermittent errors in setting up transfers and also impacting the loading of the homepage.
Posted Jul 01, 2025 - 17:15 BST
This incident affected: 📰 Website and 💸 Payments.