Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 03, 2025 - 10:00 BST
Scheduled
Our team will conduct a short scheduled maintenance on 3 June 2025 between 10am to 10:10am BST. During this time the Wise Help Centre will not be available, so customers will be unable to view articles or contact support teams. We will update this page if any issues arise. We apologise for any inconvenience this may cause and sincerely appreciate your understanding.
Posted Jun 02, 2025 - 16:29 BST
This scheduled maintenance affected: ✉️ Customer Support.