SGD transfer issue
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Apr 16, 2023 - 16:06 BST
Identified
We’re currently experiencing a technical issue affecting transfers from SGD when using bank transfer as a payment method. As a result, some transfers are currently failing. If possible, we recommend using PayNow as an alternative method.

We’re already working on it and we’ll update once the issue is resolved.
Posted Apr 16, 2023 - 14:58 BST