Transfers delayed

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 23:52 BST

Monitoring

A fix has been deployed, and we are monitoring the outcome.
Posted Mar 31, 2025 - 23:34 BST

Update

We are continuing to investigate this issue.
Posted Mar 31, 2025 - 22:00 BST

Investigating

We are currently facing an issue that we are investigating; for now, all payments (except for card payments) are delayed.
Posted Mar 31, 2025 - 21:59 BST
This incident affected: 💸 Payments.