Delay in account activity

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 16:50 BST

Monitoring

Earlier today, our team successfully completed scheduled maintenance. As a result, you may notice a slight delay in displaying your recent transaction history on your Wise account. We apologise for any inconvenience.
Posted Apr 01, 2025 - 14:02 BST
This incident affected: 💱 Account.