USD instant transfers delayed
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Dec 14, 2023 - 18:35 GMT
Identified
We're aware of an issue that's affecting USD transfers using the ACH method. As a result, some transfers might take longer than expected.

Our team's already on the case, and working to get it fixed as quickly as possible. We'll let you know once all's back in order.
Posted Dec 14, 2023 - 17:33 GMT