Global transfers delayed

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 03:26 BST

Identified

We are currently facing an issue that is impacting the speed of transfers globally. As a result, these transfers may take longer than usual. Our team is working to fix this as soon as possible.
Posted Apr 03, 2025 - 00:51 BST
This incident affected: 💸 Payments.