Issue impacting transfers

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 13:06 GMT

Investigating

We are currently experiencing an issue that is impacting the speed of some transfers. As a result, payments to or from Wise may be delayed. Our team is working to fix this as soon as possible.
Posted Feb 03, 2025 - 10:06 GMT
This incident affected: 💸 Payments.