Delay with transfers

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 12:42 BST

Investigating

We're experiencing a delay in showing the correct transfer status. However, transfers are being processed as normal. Our team is working to fix this as soon as possible.
Posted Jul 24, 2025 - 11:12 BST
This incident affected: 📱 Mobile App, 📰 Website, 💱 Account, 💸 Payments, and 🔗 API.