Issue Impacting Wise Account Top Ups
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 22:22 GMT
Identified
We’re aware of a technical issue with a service partner affecting top ups to the Wise Account. For those using a credit card or debit card multiple currencies are impacted, including: CHF, PLN, USD, NZD, AUD, HUF, RON, SGD, HKD, BRL, JPY, CAD. This is impacting transfers for these currencies as well.

For those making top ups and transfers using Apple Pay or Google Pay all currencies are impacted.

We're already working on a solution and we’ll update once the issue is resolved.
Posted Mar 16, 2023 - 21:07 GMT