Issue impacting transfer speed
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Jun 20, 2023 - 10:39 BST
Identified
We are currently experiencing an issue that is impacting the speed of transfers. As a result, all transfers may take longer than usual. Our team is working to fix this as soon as possible.
Posted Jun 20, 2023 - 07:56 BST