Instant Payments Delayed
Incident Report for Wise
Resolved
This incident has now been resolved.
Posted Sep 27, 2021 - 14:05 BST
Investigating
We’re aware of an issue that’s affecting money transfers. As a result, some transfers might take longer than expected.

Our team’s already on the case, and working to get it fixed as quickly as possible. We’ll let you know once all’s back in order.
Posted Sep 27, 2021 - 13:53 BST