Issue with transaction history
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Dec 05, 2023 - 16:10 GMT
Investigating
We're currently experiencing a technical issue. As a result, it's taking longer than usual for your transfer activity to be reflected in our transaction history on our website or mobile apps. Transfers are being processed normally.

This issue also affects API integration partners.
Posted Dec 05, 2023 - 14:07 GMT