Instant transfers delayed

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 14:46 BST

Monitoring

We were experiencing an incident impacting transfers from 10:20 to 10:45 UTC and from 11:20 till 12:50. A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2025 - 14:20 BST
This incident affected: 💸 Payments.