Issue with Instant Transfers
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Feb 12, 2024 - 11:18 GMT
Investigating
We're currently experiencing a technical issue. As a result, it takes onger than usual to process payments that are normally instant. This issue also impacts Wise Platform customers.

Our team is already working to fix this issue.
Posted Feb 12, 2024 - 10:00 GMT