A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2025 - 17:48 BST
Update
We are aware of an incident that is causing delayed transfers and intermittent issues with payins and accessing the Wise account homepage. This issue is impacting all customers including Wise Platform. We are investigating this incident and working to fix it as soon as possible.
Posted Sep 26, 2025 - 16:45 BST
Identified
We are aware of an incident that is causing delayed transfers and intermittent issues with payins and accessing the Wise account homepage. This issue is impacting all customers including Wise Platform. We are investigating this incident and working to fix it as soon as possible.
Posted Sep 26, 2025 - 16:44 BST
This incident affected: 📱 Mobile App, 📰 Website, 💸 Payments, and 🔗 API.