Issue with Wise service

Incident Report for Wise

Resolved

This incident has been resolved. All services are now operational.
Posted May 27, 2025 - 17:57 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 27, 2025 - 17:39 BST

Investigating

We are aware of an incident affecting our services for cards, registration and transfers for all customers. We are investigating this incident and working to fix this as soon as possible.
Posted May 27, 2025 - 17:23 BST
This incident affected: πŸ“± Mobile App, πŸ“° Website, πŸ’± Account, πŸ’Έ Payments, πŸ’³ Debit Card, and πŸ”— API.