Issue with transfers to EUR

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 15:23 GMT

Identified

We're aware of an issue affecting EUR payments. This is caused by a technical issue with one of our local banking partners. As a result, transfers in EUR may be taking longer than usual to arrive. Please be assured that we are actively monitoring the situation and working to resolve it
Posted Feb 28, 2025 - 11:36 GMT
This incident affected: 💸 Payments and 🔗 API.