Issue with contacting Customer Support

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 11:57 BST

Monitoring

We were experiencing an outage related to an external service provider from 07:09 UTC. As a result, customers in some countries had issues contacting our customer support team via phone and chat. The outage also affected our email response time. A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 11:29 BST
This incident affected: ✉️ Customer Support.