Interest payout delayed for customers in the US

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 17:22 BST

Identified

We are currently experiencing an issue which is delaying the payout of Interest for our customers in the US. Our team is working to fix this as soon as possible.
Posted Oct 01, 2025 - 16:09 BST
This incident affected: 💱 Account.