Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 18, 2025 - 04:00 GMT
Scheduled
Between 4:00 AM and 4:30 AM (UTC) on Tuesday, 18th of March 2025, we’ll be performing scheduled maintenance for up to 30 minutes. During this maintenance window, payouts to BRL accounts will be delayed. These payouts will be queued and automatically processed once the maintenance is complete.
This impacts Wise Platform partners too. We apologise for any inconvenience this may cause and appreciate your understanding.
Posted Mar 17, 2025 - 22:23 GMT
This scheduled maintenance affected: 📱 Mobile App, 📰 Website, 💱 Account, 💸 Payments, 💳 Debit Card, and 🔗 API.