Delayed payouts, instant payments not being processed, add money unavailable
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Jun 16, 2024 - 12:24 BST
Investigating
We are experiencing an issue with payouts which are currently delayed, instant transfers which are currently not being processed and add money which is unavailable.
We are working on a fix and to resolve this as soon as possible.
Posted Jun 16, 2024 - 11:01 BST