Issue with logging in and completing transfers
Incident Report for Wise
Resolved
On Monday, 11 Mar, between 8.07am-8.20am UTC, we experienced an issue where customers were not able to login or complete transfers. This issue impacted all customers, including Wise Platform partners. This issue has now been resolved.
Posted Mar 11, 2024 - 09:13 GMT