Issue with transfers
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Dec 10, 2024 - 10:35 GMT
Investigating
We are currently experiencing an issue affecting transfer payouts across all regions, resulting in delays. Our team is working to fix this as soon as possible.
Posted Dec 10, 2024 - 09:58 GMT
This incident affected: 💸 Payments.