Delays processing incoming payments to Wise

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 17:27 BST

Identified

Some incoming payments to Wise are taking longer than usual to appear in our systems. Payments already sent are safe and don’t need to be resent, but related transfers may be delayed. We’re working to fix this as soon as possible.
Posted Jul 10, 2026 - 11:32 BST
This incident affected: 📱 Mobile App, 📰 Website, 💱 Account, 💸 Payments, 💳 Debit Card, 🔗 API, and ✉️ Customer Support.