GBP Transfers Delayed
Incident Report for Wise
Resolved
This incident is resolved.
Posted May 15, 2024 - 12:14 BST
Identified
We are experiencing an issue with GBP transfers, which are currently delayed. We are working on a fix and to resolve this as soon as possible.
Posted May 15, 2024 - 11:36 BST