Issue impacting transfer speeds on certain currency routes

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 08:13 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2025 - 22:58 GMT

Update

We are continuing to work on a fix for this issue and will provide an update in due course.
Posted Feb 10, 2025 - 20:03 GMT

Update

Earlier today, we identified an issue affecting the speed of SWIFT transfers. Our team is continuing to work on a resolution, and delays may continue until the problem is fixed. We apologise for the inconvenience and appreciate your continued patience. We will provide another update at 8PM (UTC) unless we have further news before then.
Posted Feb 10, 2025 - 18:03 GMT

Update

Earlier today, we identified an issue affecting the speed of SWIFT transfers. Our team is actively working on a resolution, and delays may continue until the problem is fixed. We apologise for the inconvenience and appreciate your continued patience. We will provide another update at 6 PM (UTC) unless we have further news before then.
Posted Feb 10, 2025 - 15:01 GMT

Identified

We are currently experiencing an issue that is impacting the speed of SWIFT transfers on USD, EUR and GBP. As a result, these transfers may take longer than usual. Our team is working to fix this as soon as possible.
Posted Feb 10, 2025 - 08:09 GMT
This incident affected: 📱 Mobile App, 📰 Website, 💱 Account, 💸 Payments, and 🔗 API.