Technical Issue Affecting Balances and Jars held as Interest or Stocks

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 00:36 BST

Monitoring

Our teams are continuing to work on implementing a fix for this issue.
Posted Jul 08, 2025 - 00:04 BST

Identified

We're experiencing a brief technical issue affecting invested balances and jars. This impacts customers globally who have performed transactions connected to an invested balance or jar within the last trading cycle. You may see incorrect amounts reflected in your balance or jar. Our team is actively working on implementing a fix for this issue.
Posted Jul 07, 2025 - 20:48 BST
This incident affected: 💱 Account.