All Issues Resolved - We have resolved all ongoing issues affecting Wise services.
Email Processing Notice - Emails are now being processed; however, they may not be sent immediately.
Thank you for your patience and understanding.
Posted Jan 07, 2025 - 13:50 GMT
Update
Login & Sign-Up Restored We have fully resolved the login and sign-up issues on Wise.
Email Delays Ongoing Some users may experience delays in receiving emails for password or phone number changes and transfer updates. Our team is actively working to fix these delays. Thank you for your patience.
This issue also impacts those using Wise via Wise Platform partners.
Posted Jan 07, 2025 - 12:25 GMT
Identified
We're currently experiencing a technical issue. As a result, some users are not be able to access their Wise account when logging in or registering via our website or mobile app. Additionally, users are not be able to their change phone number or reset their password at this time.
Our team is already working on a solution.
Posted Jan 07, 2025 - 11:38 GMT
This incident affected: 📱 Mobile App, 📰 Website, and 🔗 API.