Wise card transactions not being processed
Incident Report for Wise
Resolved
This incident has been resolved and Wise cards are working as normal.
Posted May 08, 2024 - 15:45 BST
Identified
We have identified an issue with Wise cards where transactions are not able to be completed. We are currently investigating this issue and working to resolve it as soon as possible. We will continue to provide updates as the situation develops.
Posted May 08, 2024 - 15:09 BST