Wise Platform partners unable to create new customer profiles

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Nov 05, 2024 - 09:20 GMT

Investigating

We are currently experiencing an issue that is preventing Wise Platform partners from creating new customer profiles. Our team are working to fix this as soon as possible.
Posted Nov 05, 2024 - 05:27 GMT