Error in transfer process for UK customers
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 10:54 GMT
Identified
We’re aware of an issue affecting some users in the UK. As a result, when trying to pay for a transfer using your bank via Open Banking in our Wise app, this may return an error. Our team is already working on a solution.
Posted Jan 25, 2023 - 10:11 GMT