Issues impacting some transfers funded via FAST and PayNow

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 15:59 BST

Identified

We are currently experiencing a technical issue impacting SGD transfers from some bank accounts via FAST and PayNow. Our team is working on resolving this.
Posted Aug 05, 2025 - 14:21 BST
This incident affected: 💱 Account and 💸 Payments.