Wise.com unresponsive
Incident Report for Wise
Resolved
This incident has been resolved, and Wise.com is working as usual.
Posted Apr 30, 2024 - 18:41 BST
Investigating
Wise.com is not responding as usual, which is affecting customers’ ability to access their balances and make transfers. We are currently investigating the cause and working to resolve this issue as quickly as possible. We will continue to provide updates as the situation develops. Access via mobile apps is working as usual.
Posted Apr 30, 2024 - 18:28 BST