Instant Transfers delayed
Incident Report for Wise
Resolved
This incident has been solved.
Posted Apr 25, 2024 - 20:02 BST
Investigating
We are currently investigating an issue that is partially affecting instant transfers globally, causing delays. We’ll update accordingly as we gather more information to share.
Posted Apr 25, 2024 - 19:16 BST