[Scheduled Maintenance] - transfer payouts will be slightly delayed

Incident Report for Wise

Resolved

This incident was resolved at 1.15pm BST.
Posted Apr 29, 2025 - 02:57 BST

Identified

We will be undergoing a short scheduled maintenance today at 1.00pm BST. During this estimated 10 minute maintenance period, our customers and Wise Platform partners can continue to make transfers as normal but payouts to recipients will be delayed.
Posted Apr 28, 2025 - 07:47 BST