A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 13:45 GMT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2025 - 12:55 GMT
Investigating
We are currently experiencing an issue that is impacting the speed of transfers globally. As a result, these transfers may take longer than usual. Our team is working to fix this as soon as possible.
Posted Mar 25, 2025 - 12:08 GMT
This incident affected: 📱 Mobile App, 📰 Website, 💱 Account, 💸 Payments, and 🔗 API.