EUR payments delayed

Incident Report for Wise

Resolved

This incident has been resolved.
Posted May 21, 2025 - 11:47 BST

Identified

We're aware of an issue affecting EUR payments caused by unavailability of SCT Inst, the SEPA Instant Transfer scheme by the Eurosystem. As a result, transfers in EUR may be taking longer than usual to arrive. Please be assured that we are actively monitoring the situation and working to resolve it.
Posted May 21, 2025 - 08:58 BST
This incident affected: 💸 Payments.