Error logging in
Incident Report for Wise
Resolved
This incident has now been resolved.
Posted Sep 30, 2024 - 15:20 BST
Identified
Our system is currently experiencing a technical issue. As a result, some users may not be able to login into their Wise account. A fix has already been implemented and our systems are recovering. Some users may still experience delays.
Posted Sep 30, 2024 - 13:37 BST
This incident affected: 📱 Mobile App, 📰 Website, and 🔗 API.