Delayed AED payments

Incident Report for Wise

Update

We are continuing to work on a solution. Customers will continue to see some delays impacting AED transfers. We will update you next at 16:00 CET on September 4 the latest.
Posted Sep 03, 2026 - 12:11 BST

Update

We are continuing to work on a solution. Customers will continue to see some delays impacting AED transfers. We will update you next at 16:00 CET on September 3 the latest.
Posted Sep 02, 2026 - 12:47 BST

Update

We have identified the root cause and are working on a solution. Customers will continue to see delays impacting pending transfers. We will update you next at 16:00 CET on September 2 the latest.
Posted Sep 02, 2026 - 07:26 BST

Identified

We're aware of an issue that's affecting customers sending AED. As a result, some payments may be delayed.
This also affects Wise Platform partners.
Our team is already working on a solution. We apologise for any inconvenience.
Posted Aug 24, 2026 - 11:05 BST
This incident affects: 💸 Payments and 🔗 API.