Transfers are delayed

Incident Report for Wise

Resolved

This incident has been resolved.
Posted May 21, 2026 - 07:33 BST

Identified

Payments are currently taking longer than usual, impacting Wise customers and Wise Platform partners. We are monitoring the situation and working towards a fix.
Posted May 21, 2026 - 06:23 BST
This incident affected: 💸 Payments.